A small, hacky Rollup plugin for TypeScript https://conduitry.dev/cheap-ts
Nelze vybrat více než 25 témat Téma musí začínat písmenem nebo číslem, může obsahovat pomlčky („-“) a může být dlouhé až 35 znaků.
 
Conduitry 4293c215c6 v1.1.1 před 1 měsícem
CHANGELOG.md v1.1.1 před 1 měsícem
LICENSE update readme/homepage před 1 rokem
README.md update readme/homepage před 1 rokem
index.js avoid deprecation warning by trying this.resolve before this.resolveId před 1 měsícem
package.json v1.1.1 před 1 měsícem

README.md

rollup-plugin-cheap-ts

A hacky lightweight Rollup plugin for transpiling and bundling libraries written in TypeScript.

Installation

This is not published to npm. Install from Git tags.

Usage

Include the plugin in your rollup.config.js:

import cheapTS from 'rollup-plugin-cheap-ts';

export default {
	// ...
	plugins: [
		// ...
		cheapTS(),
		// ...
	],
};

You must have a tsconfig.json in the same directory as your rollup.config.js. This must specify a "compilerOptions"."target" of at least "ES6". There are a few other options that must not be specified. (The plugin will check for these.) All extensionless imports from .ts files must refer to .ts files.

License

MIT